Skip to content

svn tut nicht mit Eclipse und subclipse (K)Ubuntu

Ein frisch installiertes Eclipse Galileo brachte bei meinem Versuch ein Projekt auszuchecken, zunächst den Fehler: unable to connect to svn client Da gabs bei deutschen Googleergebnissen doch gleich mal ein mir gut bekanntes Blog: Guggat emol Subclipse Fehler Leider war's das allein noch nicht, denn danach kam: cannot map the project with svn provider Hier gab's auch auf Englisch keine brauchbaren Ergebnisse, die einen raten das Projekt zu verbinden, nun, ich wollte es jedoch neu, andere meinten neu installieren vom inzwischen fehlenden Subclipse, das passte alles nicht. Irgendwer schrieb mal von svnkit, das klappte zunächst jedoch auch nicht. Ich verglich mal die Einstellungen einer alten Eclipseversion und mir fiel ein, es gab schon mal ein Problem, mit JavHL bzw. SVNKit. Also nochmal beim Update (/Help/Check for Updates) versucht und alle Quellen angewählt und nochmal nach SVNKIT gesucht, dieses Mal gabs eins bei Subclipse, das habe ich installiert. Wieder ein Checkout versucht über den Weg Checkout using new Wizard, irgendwo da habe ich mich wohl verklickt, denn wieder wollte es nicht. Also mal kurz geprüft, ob die Grundeinstellungen passen müssten, sah gut aus soweit und dann über: Checkout as a project in the workspace Zwei- dreimal ok sagen und JUHU! Kaum macht man's richtig geht's! Die ersten Projekte ließen sich jetzt schon mal auschecken. :)

Trackbacks

Keine Trackbacks

Kommentare

onli am :

onli Ich habe mich damit auch rumgeschlagen. Ein ernsthaftes Projekt, keine Freizeit, svn und also subclipse vom Team gewählt. Bei der Version in den Ubuntuquellen habe ich es erstmal gar nicht installiert bekommen, wahrscheinlich fehlten irgendwelche Abhängigkeiten. Erst mit der aktuellen Eclipseversion war da was zu machen, löst die wohl besser auf. Ich meine mich aber zu erinnern, es bei einem Debian mit der 3.2 zum laufen bekommen zu haben, dort klappte dann aber das auschecken nicht.

Gestern war die Krönung: Am abend zuvor den Laptop vorbereitet, neues Eclipse, ausgecheckt, Programm lief. Am nächsten morgen beim Treffen zum Arbeiten dann nicht mehr - gleichzeitig wollte das Internet nicht. Ich hatte den Fehler gemacht, Eclipse 3.2 zu starten, dachte ich zumindest. Dann aber: Internetverbindung hinbekommen, Ordner im workspace komplett gelöscht, neu ausgecheckt: Wieder die gleiche Fehlermeldung. Irgendwas hats da zerrissen. An einem anderen PC läufts einwandfrei (und die grundlegenden Dinge stimmen überein, Javversion, eingebundene jars usw). So konnte man dann doch die Arbeit erledigen, aber nervig waren die Fehler schon.

Ich erwarte keine Lösungsvorschläge, ich wollte nur darauf hinweisen, wie typisch solche Probleme sind :)

ute am :

ute Ja, ich weiß Eclipse ist schon immer etwas zickig. Deshalb nutze ich meist lange eine Version, wenn die grad mal läuft.

Aber wenn es dann tut, dann ist es grad für svn schon komfortabel. Beim Ein- und Auschecken mag ich ja auch die Konsole, aber wenn ich was suche, dann ist die History (wenn vernünftig kommentiert wurde) der Konsole doch überlegen, inklusive des integrierten Compare hat das schon was.

Alte Eclipseversionen werfe ich möglichst gleich runter, sonst bin ich dann völlig irritiert... Aber beruhigend, wenn es nicht nur mir so geht. ;)

Drück dir die Dauemen, dass du es beim nächsten Versuch repariert kriegst.

Christian am :

Christian Gibt es Alternative zu der Software "Eclipse" unter Ubuntu?
Vielen Dank.

onli am :

onli Natürlich. Aber welche Alternative geeignet ist hängt stark davon ab, wofür man Eclipse derzeit nutzt. Normale Javaprogrammierung mit Versionsverwaltung? Welche Funktionen braucht man unbedingt? Je nachdem tut es ein guter Editor wie geany oder eine der Enticklungsumgebungen: http://wiki.ubuntuusers.de/Entwicklungsumgebungen .
Gruß

ute am :

ute Ich kann onli nur zustimmen, kommt wirklich sehr darauf an.

Auch wenn Eclipse ein recht dicker - zuweilen sehr langsamer - Klotz ist, es hat auch Vorzüge. Für unsere Webprojekte nutzen wir es für: SVN und PHP
Bei HTML- und CSS-Dateien finde ich ist Quanta erheblich komfortabler, aber der verschluckt sich sehr leicht an PHP, mehr als eine Zeile würde ich damit nicht ändern.

Kommentar schreiben

Die angegebene E-Mail-Adresse wird nicht dargestellt, sondern nur für eventuelle Benachrichtigungen verwendet.

Um maschinelle und automatische Übertragung von Spamkommentaren zu verhindern, bitte die Zeichenfolge im dargestellten Bild in der Eingabemaske eintragen. Nur wenn die Zeichenfolge richtig eingegeben wurde, kann der Kommentar angenommen werden. Bitte beachten, dass Ihr Browser Cookies unterstützen muss, um dieses Verfahren anzuwenden.
CAPTCHA

Umschließende Sterne heben ein Wort hervor (*wort*), per _wort_ kann ein Wort unterstrichen werden.
Standard-Text Smilies wie :-) und ;-) werden zu Bildern konvertiert.
BBCode-Formatierung erlaubt
Gravatar, Twitter, Favatar Autoren-Bilder werden unterstützt.
tweetbackcheck