Skip to content

Fehlersuche und aktualisieren auf WP 2.7

Ich bin ja seit ein paar Tagen an einigen Ecken an den Blogs und bastele dran rum. Teils die Optik, teils die Funktionen, teils die Anpassungen am Theme, um es für die Wordpressversion 2.7 lauffähig zu bekommen. Einige Funktionen und Plugins habe ich inzwischen beim ein oder anderen Blog hinzugefügt, manches Plugin fordert doch noch einige Anpassungen, bis es genau das tut, was ich wollte. Im Großen und Ganzen hat nach ein bisschen Überredungskunst das meiste soweit geklappt. Mit dem Update-Hinweis hatte ich kein größeres Problem, der ließ sich leicht abstellen. Aber leider bleibt ein dickes Problem:

Wp 2.7 Adminbereich im Dashboard nur Menü, kein Inhalt

Ja, alles andere geht, ich kann hier schreiben, Kommentare funktionieren, Plugins de- und aktivieren geht usw. Aber das Dashboard selbst, hat das Menü und die Kopfzeile und sonst nichts. Bei anderen Blogs mit denselben Dateien und ähnlichem Aktualsierungsverlauf geht es, hier geht es nicht.

Das Problem begann mit irgendeiner 2.6x glaube ich:

Mit 2.6 konnte ich noch den Link ändern, dann erschien der Inhalt. Klar, das war etwas lästig, aber möglich. Seit 2.7 bleibt das Dashboard leer, da ist das Menü und sonst nichts. Bei anderen Installationen klappt alles, nur hier nicht

Gemeldet habe ich das inzwischen dickere Problem hier:

#8260 (A false linking to dashboard in the sidebar after upgrade) - WordPress Trac - Trac Nach vergeblicher Suche einer Lösung habe ich mal in den relevanten Threads beim deutschen Wordpress-Forum um beim Supportforum von WordPress nachgefragt.

Vergebliche Lösungsversuche

Übrigens, ja ich habe alles versucht, was mir einfiel. Das Problem besteht sowohl bei der lokalen Installation als auch bei der Liveversion. Mir war es lokal nicht aufgefallen, da lokal das Dashboard ja nicht so wichtig ist, beim Testen nutze ich alle anderen Administrationsseiten stärker, als jetzt diese. Ursprünglich hatte ich gehofft, das Linkproblem wäre bei einer neuen Version dann weg. Dass es jetzt erst noch da war, aber kein Inhalt mehr ist lästig. Nach dem Umbenennen aller leeren index.php-Dateien in index.html war tatsächlich das Linkproblem weg, das ist schön. Ich habe jedoch immernoch keinen Inhalt im Dashboard. Ich habe Plugins de- und aktiviert, gelöscht neu hochgespielt. Ich habe alle, aus meiner Sicht eventuell in Frage kommenden WP-Dateien nochmal geprüft, ob sie wirklich so sind, wie auf den Blogs, auf denen alles klappt. Ich mit dem Adminize-Plugin gespielt, nicht nur mit de- und aktivieren, sondern auch mit den Menüeinstellungen, aber es half alles nichts. Egal ob:
  • mit oder ohne Plugins
  • mehrfaches Hochspielen
  • Themes und Einstellungen ändern
  • Logfiles nach relevanten Einträgen absuchen
  • ...
die Seite bleibt leer. Falls irgendjemand noch eine Idee hat, ich würde mich sehr freuen...

Trackbacks

» Plugins automatisch aktualisieren : testen : WP Kommentarfeed (comments am :

"" vollständig lesen
[...] bloggt bei WordPress und Plugins : nicht immer problemlos…ute bei Fehlersuche und aktualisieren auf WP 2.7Dieter bei Fehlersuche und aktualisieren auf WP 2.7ute bei Fehlersuche und aktualisieren auf WP [...]

Fehlersuche am Beispiel: Inhalt im Dashboard fehlt bei WordPress 2.7  &raqu am :

"" vollständig lesen
[...] schon berichtet, hatte ich hier den Fehler, dass kein Inhalt mehr angezeigt [...]

Kommentare

ute am :

ute Grummel, großes Danke an Dieter, der mich per Mail drauf aufmerksam machte, dass hier niemand kommentieren konnte...

Ist jetzt repariert, hoffe ich...

Sorry...

Am Dashboard-Problem ändert das jedoch leider nichts...

Dieter am :

Dieter Manchmal muss man(n) (Frau auch ;-) ) sich auch an kleinen Dingen erfreuen. Schön, dass die Kommentarfunktion wieder funktioniert. Ich bin sehr zuversichtlich, dass Du das Dashboard-Problem auch noch gelöst bekommst. Hast Du denn schon alle PHP-Einstellungen (z.B. mit phpinfo ()) überprüft und mit denen bei einem funktionieren Blog verglichen?

ute am :

ute Ja, hab alles geprüft, mal ganz grundsätzlich. Obwohl ich ganz sicher weiß, dass auf dieser Domain, auf diesem Server ein nicht-öffentliches Blog problemlos mit denselben Dateien, Plugins, Einstellungen und fast identischem Theme auf 2.7 läuft...

ute am :

ute Dieter said:


Schön, dass die Kommentarfunktion wieder funktioniert


Noch schöner wäre gewesen, wenn ich nicht Stunden nach validen Lösungen gesucht hätte... Später oder morgen mehr dazu...

Kommentar schreiben

Die angegebene E-Mail-Adresse wird nicht dargestellt, sondern nur für eventuelle Benachrichtigungen verwendet.

Um maschinelle und automatische Übertragung von Spamkommentaren zu verhindern, bitte die Zeichenfolge im dargestellten Bild in der Eingabemaske eintragen. Nur wenn die Zeichenfolge richtig eingegeben wurde, kann der Kommentar angenommen werden. Bitte beachten, dass Ihr Browser Cookies unterstützen muss, um dieses Verfahren anzuwenden.
CAPTCHA

Umschließende Sterne heben ein Wort hervor (*wort*), per _wort_ kann ein Wort unterstrichen werden.
Standard-Text Smilies wie :-) und ;-) werden zu Bildern konvertiert.
BBCode-Formatierung erlaubt
Gravatar, Twitter, Favatar Autoren-Bilder werden unterstützt.
tweetbackcheck