Skip to content

...jetzt doch Update auf (K)Ubuntu Maverick

Ich habe ja letztens schon ein bissel was zu Ubuntu LTS und Kubuntu und so… geschrieben. Heute habe ich mal nachgesehen, was aktualisiert werden würde, sofern ich mich zu einer Aktualisierung innerhalb von Lucid per backport entscheiden würde. Das habe ich direkt abgebrochen, denn gerade die Stellen - die mir wichtig wären - würden eben nicht geändert sondern wären geblockt. Eine "halblebige" Version von Lucid LTS (Long Term Support) klingt schon nach zusätzlichen Problemen. Nach einem kurzen Blick auf die Änderungen beim vollständigen Update auf die Meerkatze (Maverick Meerkat aka Ubuntu 10.10 aka eigensinniges Erdmännchen)  beschloss ich daher es zu riskieren.  Nach einem aktuellen Backup aller relevanten Daten auf unseren Fileserver startete ich das Ding und hoffte, dass es klappt... Das Ding erzählte tolle Geschichten von Runterladen und Installieren und Rechner neu starten und überhaupt... Insgesamt waren das schon gut zwei Stunden... Huch, irgendwann bewegte sich was, ich dachte jetzt kämen die Fragen... Nee, doch nicht, das Ding war nebenbei abgestürzt. ;) Nun gut, unterm Strich entfernte er dabei zumindest nicht, was er ursprünglich behauptete löschen zu wollen...

Nach der Aktualisierung auf die Meerkatze

Zunächst einmal ging es deutlich besser als erhofft, zumindest ein bisschen im Web surfen und mit identi.ca und twitter arbeiten, ging bis kurz bevor alles fertig war. :) Meine Hauptgründe fürs Update waren:
  • akonadi stürzte ständig ab, sobald ich im kontact irgendetwas außer Mails nutzte (Adressbuch, Usenet, RSS, Kalender...) Bug wurde in KDE 4.5 repariert: https://bugs.kde.org/show_bug.cgi?id=236355 (scheint bisher zu laufen)
  • konqueror versteht keine localhost-Adresse mehr, Bug wurde in KDE 4.5 repariert: https://bugs.kde.org/show_bug.cgi?id=249204 (kann zunächst wohl sowohl localhost wieder und zickt bislang auch bei sftp nicht mehr)
  • kscreensaver Diaschau, kann nur mit Querformat bei Bildern, Bug wurde für KDE 4.5.2 repariert: https://bugs.kde.org/show_bug.cgi?id=253771 (hier muss ich noch warten, aber ich hoffe doch, dass die Meerkatze bald auch KDE 4.5.2 bekommt...)
Die ersten Tests:
  • Gleich beim ersten Testen fror die Kiste völlig ein und war mit nichts außer dem großen Knopf dazu zu bewegen sich abzuschalten.
  • Quanta, GIMP, Eclipse, OpenOffice, Virtualbox usw. verhalten sich wie erhofft unverändert und ohne Probleme
  • alle installierten Browser verhalten sich brav, nur Firefox hatte sein Flashplugin verloren, dafür läuft Java noch wie erhofft
  • kontact (inklusive akonadi) scheint nach den ersten Tests wieder sauber zu laufen, zunächst zickte es noch ein bisschen, doch nach mehrfachem Ab- und Anmelden und damit kontact neu starten scheinen diese Fehler jetzt weg zu sein.
  • Im Dolphin hat's mal wieder ein paar Ansichten verhagelt, das ist ärgerlich, aber war bisher jedesmal so, also kein Weltuntergang (siehe Screenshot, die Symbole werden nicht vollständig angezeigt)
  • KDE μ-Blog hab ich in den letzten Versionen schon mal probiert, aber bisher nur ganz kurz, weil es völlig unbrauchbar war. Inzwischen ist es in der Kontrollleiste integriert und auf den ersten Blick wirkt es ganz spannend.
  • insgesamt wirkt das Ganze kaum verändert, die wenigen Kleinigkeiten, die auf Anhieb auffallen sind eher angenehm als ungewohnt (die anderen Symbole in der Kontrollleiste beispielsweise)
  • jetzt hoffe ich, dass sich das Erdmännchen nicht zu eigensinnig sondern vor allem weiterhin stabil verhält und ich zumindest die ganz lästigen Fehler los bin... :) (Gesamtaufwand war jetzt alles in allem rund 8 Stunden inklusive aller Tests)

...und jedes Quartal eine Überraschung mit der Elster

Ich bin ja wie schon mehrfach beschrieben nicht gerade geschickt mit der Elster, siehe auch Umsatzsteuervoranmeldung mit Elster.
  • elster online erfolgreichelsteronline: es hat geklappt...

Doch, dass es wirklich pro Quartal einen Grund für einen Artikel gibt ist schon beeindruckend. Nach der Anleitung schrieb ich das nächste Mal über die Jahresmeldungen, die natürlich wieder nicht  mit elsteronline.de möglich sind.

"...und jedes Quartal eine Überraschung mit der Elster" vollständig lesen

Elster Problem beim Anmelden und/oder Absenden Firefox auf Ubuntu

Letztens habe ich mal wieder die Elster gebraucht, dieses Mal auf einem System, auf dem ich es bisher noch nicht genutzt hatte. Es ging darum die Umsatzsteuervoranmeldung zu versenden. Prompt trat jedoch bereits beim Versuch mich mittels Zertifikat einzuloggen ein Fehler auf:
  • ein Klick auf Login führte zu einem Absturz des Applets mit dem Hinweis auf: java.lang.NullPointerException
Zunächst suchte ich im Forum bei Elster selbst, da gab es zwar einen Thread aber noch nicht die Lösung: Elster Anwenderforum Ein Hinweis führte jedoch zum Thread auf ubuntuusers.de dort ist beschrieben, dass der Symlink geändert werden muss: cd /etc/alternatives sudo mv mozilla-javaplugin.so mozilla-javaplugin_OriginalOpenJDK-link.so sudo ln -si /usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so mozilla-javaplugin.so Bei mir sieht unter /etc/alternatives/ ls -la jetzt so aus: lrwxrwxrwx   1 root root    48 2010-01-13 14:12 mozilla-javaplugin_OriginalOpenJDK-link.so -> /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so lrwxrwxrwx   1 root root    64 2010-01-13 15:08 mozilla-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so und funktioniert. Sobald ich die Anleitung gefunden hatte, war das Problem also gelöst, danke an den freundlichen Menschen, der das ins Forum bei ubuntuusers.de schrieb. :)

...wieder mal Firefox Add-Ons, Plugins usw.

Prinzzess mag grad in ihrer Blogparade wissen, welche Add-ons, man nutzt; teilnehmen könnt ihr noch bis zum 20.8. Ich nutze die Gelegenheit, um hier meine aktualisierte Liste der Add-Ons und Plugins aufzuführen, die ich jetzt noch mit Firefox 3 nutze, im Artikel über den Firefox 2 habe ich mich ja schon mal recht ausführlich über Vor- und Nachteile ausgelassen... Mein Firefox hat einige zusätzliche Add-ons:
  • Web Developer (essenziell, um Webseiten zu entwickeln)
  • Adblock Plus (damit kommt fast gar keine Werbung mehr durch)
  • Deutsches Wörterbuch, praktisch beim Blogbeiträge schreiben
  • Flashblock, damit suche ich mir aus, was ich sehen will und was nicht
  • ColorZilla (geht jedoch nicht in der aktuellen Version mit 2.0.0.3, aber mit 2.0.0.11)
  • Colour Contrast Analyser (Farbkontraste der benutzten Farben prüfen)
  • DOM Inspector (für schnelle Checks von Problemen auf Webseiten sehr praktisch)
  • PDF Download (auf Linux sinnvoll, damit ein PDF direkt nach dem Runterladen geöffnet wird)
  • Screen grab! (Screenshots sind auch von ganzen Seiten in voller Länge möglich, brauche ich nicht oft, aber ab und zu ganz praktisch)
  • SearchStatus (zwei Tools zum PageRank, weil beide ab und zu mal ausfallen, eins geht meist)
Hinzu kommen ein paar Plugins überwiegend für Videos und ähnliches, mehr dazu siehe auch Artikel zu ZDF Mediathek einbinden:
  • Helix DNA-Plugin (manche Videos RealPlayer-Format)
  • Java(TM)
  • mplayerplugin
  • OpenOffice.org Plugin
  • Shockwave Flash
  • VLC Multimedia Plug-in
Das ein oder andere mit Firefox 2 genutzte Plugin gibts noch nicht für die Version 3, aber dafür habe ich ja den Firefox href="http://miradlo.net/bloggt/index.php?58-s"">Artikel zu ZDF Mediathek einbinden:
  • Helix DNA-Plugin (manche Videos RealPlayer-Format)
  • Java(TM)
  • mplayerplugin
  • OpenOffice.org Plugin
  • Shockwave Flash
  • VLC Multimedia Plug-in
Das ein oder andere mit Firefox 2 genutzte Plugin gibts noch nicht für die Version 3, aber dafür habe ich ja den Firefox 2.0.0.14 noch auf dem Rechner und kann es dort nutzen. Falls das nicht passt, gibts ja noch mehr Browser, siehe Vorlieben bei der Browsernutzung.href="http://miradlo.net/bloggt/index.php?138-s"">Vorlieben bei der Browsernutzung.

Eclipse 3.3.1.1, JUnit4 und Gentoo

Ich hatte letzte Woche das Problem, dass ich ein paar Javaklassen mit JUnit testen wollte. Als ich JUnit startete, trat folgender Fehler auf:

java.lang.NoClassDefFoundError: org/hamcrest/SelfDescribing at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:620) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124) at java.net.URLClassLoader.defineClass(URLClassLoader.java:260) at java.net.URLClassLoader.access$100(URLClassLoader.java:56) at java.net.URLClassLoader$1.run(URLClassLoader.java:195) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:188) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268) at java.lang.ClassLoader.loadClass(ClassLoader.java:251) at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319) at org.junit.internal.runners.JUnit4ClassRunner.run(JUnit4ClassRunner.java:42) at org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:38) at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:460) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:673) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:386) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:196) Das Problem ist, dass im aktuellen eBuild von Gentoo die aktuelle JUnit Version (JUnit 4_4.3.1) installiert wird. Lösung:

  • Build Path->Configue BuildPath auswählen
  • Die neue Version von JUnit4 entfernen.
  • Im .eclipse/org.eclipse.platform_3.3.0_1169174242/configuration/eclipse/plugins die Version org.junit4_4.1.0.1 installieren und über „externe Jars“ einbinden.
Und schon klappts mit dem JUnit auch wieder ;)

tweetbackcheck