Skip to content

Firefox, Opera, Browser im WordPress Adminbereich und ihre Wirkung, z.B. auf Icons

Screenshot utele_wp_admin_icons verschobenMein Problem mit der Geschwindigkeit ließ sich ja eindeutig auf den Firefox zurückführen. Daher setze ich in den letzten Tagen für die Adminbereiche von WordPress Opera ein, denn dreimal schneller ist schon ein sehr klares Argument. Leider verhält sich Opera jedoch nicht wie Firefox. Für mich ist Opera so wie im Moment nicht auf Dauer benutzbar.
  1. normalerweise kann Opera so wie Firefox auch etwas mit der mittleren Maustaste Kopiertes wieder einfügen. Das klappt z.B. um einen Link in die Adressleiste einzufügen. Es klappt jedoch nicht, wenn ich kopierten Text im WordPress-Editor einfügen will, dann öffnet er eine Suchseite oder wechselt zum Linkziel oder so. Er tut jedenfalls nicht, was ich will, nämlich schlicht den Text einfügen.
  2. Beim Überfahren (hover) von Links zeigt mein Firefox mir brav das Linkziel, ich nutze das häufig. Firefox kann es nicht im Adminbereich von WordPress oder bei manchen merkwürdig mit JavaScript erstellten Seiten. Opera allerdings kann es gar nicht, zumindest konnte ich keine Einstellung finden, die mir das ermöglicht.
  3. Von Opera werden keine automatischen Ergänzungen bei Formulareingaben angeboten, wer das wie ich gewohnt ist, ist deutlich irritiert, wenn es fehlt.
  4. Bis hierhin wäre es noch akzeptabel, jetzt kommt jedoch noch ein Bug dazu, mit dem kann ich nicht arbeiten. Schreibe ich mit Opera im TinyMCE von WordPress in der visuellen Ansicht, dann killt Opera alle Zeilenumbrüche und Absätze. Listen und Überschriften sind möglich, alles andere verschwindet einfach. Aus einem nett formatierten Beitrag wird plötzlich eine Textsuppe ohne Absatz oder Zeilenumbruch.
miradlo_bloggt Screenshot wp_admin_icons verschobenBleibe ich in der HTML-Ansicht ist alles ok, dann bleiben Absätze und Zeilenumbrüche auch mit Opera erhalten, aber ein Wechsel mit Speichern zur visuellen Ansicht und alle Umbrüche sind weg. Damit ist Opera definitiv keine Dauerlösung, denn so kann ich nicht arbeiten. Ja, ich weiß es gibt andere Wege mit benutzerdefinierten Feldern und in HTML-Ansicht zu arbeiten. Mir geht's jedoch nicht nur um mich und meine Möglichkeiten, sondern es geht auch um ungeübte Nutzer. Einer der Gründe WordPress zu nutzen ist ja der einfach Editor, der ähnlich wie die gewohnten Office-Programme funktioniert.

Icons (Symbole) im Adminbereich verschoben

Screenshot utele_wp_admin_icons Opera

Vor kurzem habe ich auf uteles Blog einige Beiträge mit Videos erstellt. Nach mehrfachem Testen und Recherchieren fand ich einen recht einfachen Weg, die Dinger auch in valider Version da reinzubasteln. Auf keinen Fall klappte es mit dem ganz offensichtlichen Button gleich oberhalb unter "Hochladen/Einfügen". In der Reihe der erweiterten Symbole für den TinyMCE gibt es jedoch noch einen Knopf "Medien hinzufügen". Über diesen ließen sich relativ schnell die Videos so einbinden, dass nicht alles mögliche hinzugefügt wird, was ich nicht haben will und nachher zu invaliden Seiten führt. Ich erstellte nacheinander mehrere Beiträge mit Videos, und irgendwann zerbröselte die Optik im Adminbereich. Ich bin einiges gewöhnt und beschloss es zu ignorieren, weil ich annahm, dass nach dem nächsten Booten alles wieder passt.

Das war nicht so, in uteles Blog blieben die Symbole und Beschriftungen verschoben. Nun gut, auch das ist kein Weltuntergang, ich suchte also nicht, sondern ließ es einfach so.

Worauf ich jedoch nicht gekommen wäre: Auch das ist ein Fehler, der browserabhängig ist, denn im Opera sieht auch uteles Blog so aus, wie die anderen, da ist kein Symbol verschoben. Browserfehler im Sinne von, etwas sieht in einem Browser etwas anders aus, als im nächsten kenne ich ja, aber was mir neu war, sind so starke Auswirkungen auf einen Browser, weil er sich bei einer Aktion mal verschluckt hat... Da Opera also auch noch keine echte Alternative ist, habe ich mal weiter getestet, mehr dazu, demnächst...

tweetbackcheck